Back to overview
Downtime
Upstream Network Issues
May 7, 2026 at 6:53am UTC
Affected services
DirectAdmin
Dango Portal
Payments
Commissions
Homepage
MyDangoID
DangoID
DangoAPI
CMS
Built-in CDN
Daily DirectAdmin Backups
Resolved
May 7, 2026 at 8:22am UTC
Everything is back up and working as normal.
Affected services
Created
May 7, 2026 at 6:53am UTC
We are aware of 522 connection timed out errors across all Web Hosting and Email Hosting services. We're currently investigating the issue and it should be resolved shortly.
Affected services