Server Outage
Resolved
Nov 16 at 10:26pm EST
All services have been restored.
Affected services
Updated
Nov 16 at 09:59pm EST
The issue has been identified and is currently being mitigated.
Affected services
Created
Nov 16 at 09:46pm EST
We are aware that Web Hosting and Email Hosting services are down at the moment. We are investigating the cause of this issue.
Affected services